WordPress est l'un des meilleurs systèmes de gestion de contenu (CMS) open source, utilisé par des millions de personnes et de développeurs pour répondre à leurs besoins. Grâce à son interface utilisateur et à ses fonctionnalités exceptionnelles, WordPress devient chaque jour plus simple et performant. La création et la gestion d'un site WordPress sont simplifiées et rapides grâce au travail de nombreux développeurs à travers le monde.
Même si la configuration et l'exécution d'un WordPress sont très simples, les gens sont incapables d'exécuter un WordPress avec succès pendant longtemps. La raison en est que les gens ont peur de dépanner WordPress, car la résolution des problèmes sur WordPress nécessite une certaine expertise et des connaissances techniques.
Il est toujours fortement recommandé de faire une sauvegarde de votre site Web avant d'essayer de résoudre les problèmes sur votre site. Et c'est aussi une bonne idée de tester sur le site Web hôte local ou sur un site Web intermédiaire avant d'apporter des modifications sur votre site.
1)Récupérez le mot de passe administrateur perdu.
Si vous avez perdu votre mot de passe administrateur et que vous n'avez pas accès à l'adresse e-mail qui a lié votre compte WordPress et que vous ne pouvez pas accéder à votre tableau de bord d'administration WordPress, ne vous inquiétez pas, nous pouvons vraiment résoudre le problème en vous connectant à votre compte d'hébergement. .Il existe deux façons de récupérer votre mot de passe administrateur
Façons de récupérer le mot de passe administrateur
1) Depuis PhpMyAdmin : -
Vous pouvez simplement réinitialiser le mot de passe de votre compte WordPress à partir de votre tableau de bord PhpMyAdmin. Connectez-vous à votre tableau de bord PhpMyAdmin.
2) Maintenant, cliquez sur la base de données de votre site. Si vous exécutez plusieurs sites, il y aura plusieurs bases de données, sélectionnez celle qui appartient à votre site. Si vous ne parvenez pas à sélectionner la bonne base de données, cliquez sur la base de données et ouvrez le wp -tableau d'options, vous pouvez trouver la ligne avec le nom du site auquel appartient la base de données. C'est ainsi que vous pouvez trouver la base de données de votre site.
3) Cliquez maintenant sur le tableau wp-users comme indiqué dans l'image ci-dessous.
4) Sélectionnez maintenant votre compte et cliquez sur modifier comme indiqué dans l'image ci-dessous.
5) Maintenant, dans la zone user_pass, remplacez le code de hachage MD5 complet par votre nouveau mot de passe et sélectionnez la fonction MD5 dans la liste déroulante comme indiqué dans l'image ci-dessous.
6) Maintenant, cliquez sur le bouton GO, pour réinitialiser votre mot de passe.
Ça y est vous avez changé votre mot de passe. Connectez-vous maintenant à votre WordPress avec votre nouveau mot de passe.
Vous pouvez également modifier le mot de passe d'autres comptes WordPress sur votre site. En tant qu'administrateur, vous n'avez pas besoin de venir ici sur PhpMyAdmin, vous pouvez modifier directement le mot de passe à partir du tableau de bord WordPress en ouvrant le profil de l'utilisateur et en entrant le nouveau mot de passe.
Si vous voulez connaître une autre méthode, continuez à lire la deuxième méthode.
2) Modification du fichier funtions.php
- Ouvrez votre panneau de contrôle.
- Ouvrez le gestionnaire de fichiers
- Allez dans votre dossier Thème actuel, il sera ici /wp-content/themes/theme-actuel/ et ensuite cherchez fonctions.php fichier.
- Téléchargez maintenant le fichier en tant que copie de sauvegarde.
- Une fois le téléchargement terminé, cliquez sur éditer
Et entrez la fonction suivante dans le fichier comme indiqué dans l'image ci-dessous.
wp_set_password('MyNewPassword',1);//function to rest password with user id 1
Dans la ligne ci-dessus, remplacez « VotreNouveauMotDePasse » par le mot de passe souhaité et « 1 » par l'identifiant de votre compte WordPress . La valeur par défaut est 1 ; vous n'avez donc pas besoin de la modifier si le compte que vous utilisez a été créé lors de l'installation de WordPress. En effet, certains plugins de sécurité modifient l'identifiant du compte administrateur pour des raisons de sécurité. Cette méthode peut ne pas fonctionner. Si vous parvenez à vous connecter à votre compte, c'est parfait : une fois connecté, supprimez simplement la ligne du fichier functions.php.
Cliquez maintenant sur Enregistrer.
Après vous être connecté, n'oubliez pas de revenir au fichier et de supprimer la ligne. Si vous oubliez, votre mot de passe est réinitialisé à chaque fois qu'une page est chargée sur votre site. N'oubliez donc pas de supprimer la ligne.
2) Écran blanc de la mort (WSD):-
White Screen Of Death est l'un des problèmes les plus ennuyeux avec WordPress. Ceci est généralement causé par les thèmes et les plugins mal codés et les erreurs de base de données. White Screen Of Death est une erreur qui affiche des pages blanches.
Il n'y a pas de solution spécifique pour résoudre ce problème car il y a plusieurs raisons pour lesquelles cette erreur se produit. Avant de demander de l'aide pour votre problème, vous devez recueillir des informations sur le problème, comme la cause du problème et comment.
Pour obtenir ces informations, faites ces
Trouver le plug-in coupable : -
Comme mentionné ci-dessus, le plugin mal codé peut causer ce problème. Pour savoir quel plugin a cassé votre site, vous devez désactiver les plugins un par un. Et consultez le site. Si vous n'avez pas accès au tableau de bord WordPress en raison de cet écran vide, vous devez désactiver les plugins du gestionnaire de fichiers en renommant le dossier des plugins en votre nom qui vous convient généralement (plugin_old) qui est présent à wp-content/plugins.
Ensuite, téléchargez les plugins depuis votre dossier plugins et essayez de les installer. Un par un pour découvrir le plugin coupable !.
Après avoir identifié le plugin à l'origine du problème, ouvrez un sujet sur la page d'assistance des plugins WordPress (Notez que ce forum ne peut vous apporter d'assistance que pour les plugins gratuits disponibles sur le répertoire WordPress. Si vous utilisez un plugin premium, il est préférable de contacter le développeur du plugin pour résoudre votre problème).
Thème:-
Si vous ne trouvez pas le problème à l'origine des plugins, il se peut qu'il soit dans le thème à l'origine du problème. Pour connaître le thème à l'origine du problème, renommez simplement votre thème actuel en theme_old et connectez-vous maintenant au tableau de bord WordPress et activez les thèmes WordPress par défaut. (Twenty-Thirteen mon thème préféré).
Et si vous rencontrez toujours le problème, vérifiez les journaux d'erreurs sur votre hôte qui révèlent des informations importantes pour résoudre le problème. (S'il vous plaît Google sur Comment vérifier les journaux d'erreurs).
3) Erreur lors de l'établissement d'une connexion à la base de données : -
Cette erreur sur votre site indique que votre site WordPress est incapable de se connecter à la base de données de votre site. Cette erreur est également due à plusieurs raisons. L'une des principales raisons est due au trafic important sur votre site (Pour confirmer cela, vérifiez votre numéro de visites avant le site montrant l'erreur sur votre site à partir de Google Analytics S'il y a une augmentation de votre trafic, alors mieux vaut mettre à jour votre planification d'hébergement) Et une autre raison peut être que votre site pourrait être piraté. faire avant de prendre le temps de trouver la raison du problème.
Notez avant d'essayer ceci, faites une copie de sauvegarde de votre base de données.
Étape 1:-
Ouvrez votre gestionnaire de fichiers
Étape 2:-
Sélectionnez maintenant le fichier wp-config.php et cliquez sur Modifier comme indiqué dans l'image ci-dessous.
Étape 3 : Ajoutez maintenant la ligne suivante au fichier wp-config.php comme indiqué dans l’image ci-dessous et cliquez sur Enregistrer.
Étape 4:- Maintenant, après avoir enregistré, ouvrez ce lien
http://yoursitename.com/wp-admin/maint/repair.php
n'oubliez pas de remplacer votre nom de site dans la ligne ci-dessus :-P.
WordPress va maintenant lancer un outil de réparation automatique de base de données. Comme le montre l'image, cliquez sur Réparer la base de données (vous pouvez choisir n'importe quelle option selon vos besoins).
Étape 5 : Une fois la réparation de la base de données terminée, vous recevrez un message de confirmation (voir image ci-dessous). Ouvrez ensuite le fichier wp-config.php et supprimez la ligne que vous aviez ajoutée. Cette méthode permet d'accéder à votre base de données sans connexion. Si des personnes mal intentionnées la découvrent, elles pourraient l'utiliser pour la verrouiller à leur guise (la base de données sera verrouillée pendant la réparation).
Si votre problème n'est toujours pas résolu, il est préférable de contacter votre hébergeur.
4) Non disponible pour la maintenance programmée : -
Cette erreur se produit en raison de mises à jour incomplètes du noyau WordPress. Résoudre ce problème est si simple. Tout ce dont vous avez besoin est de simplement supprimer le fichier .maintenance qui sera présent dans le dossier racine de votre site Web.
5) Erreur de serveur interne :-
C'est l'erreur que je déteste le plus. Parce que trouver la cause du problème prend beaucoup de temps. Ce problème est causé par plusieurs raisons. Voici quelques étapes que vous devez suivre avant de sauter pour découvrir le problème.
Ce problème est généralement causé par le fichier .HTACCESS corrompu. Recherchez donc ce fichier dans le dossier racine de votre site Web et renommez-le. (Notez que vous devez cocher la case pour afficher les fichiers de points si vous utilisez le gestionnaire de fichiers sur votre site.)
Vérifiez maintenant si votre site fonctionne correctement ou non, puis essayez de désactiver les plugins et les thèmes (voir Mort sur écran blanc).
Même si cela ne fonctionne pas, essayez de remplacer les fichiers wp-admin et wp-include à partir d'une nouvelle installation (recommandez de faire une nouvelle installation sur votre hébergement actuel, puis de copier les fichiers dans les répertoires actuels).
Comme il s'agit d'un problème peu compliqué dans WordPress, il est préférable de prendre l'avis d'un expert avant de faire quoi que ce soit sur votre site. Sinon, vous pouvez gâcher votre site.
6) Erreur fatale : taille de la mémoire autorisée épuisée
Cette erreur est provoquée lors du téléchargement du fichier supérieur à votre limite de téléchargement. Chaque hébergement a ses propres limites de téléchargement, donc commencez par connaître la limite de téléchargement de votre hébergement. Vous pouvez résoudre ce problème de 3 manières.
1) Modification de PHP.ini
Résoudre ce problème est si simple. Trouvez le fichier PHP.ini dans le répertoire Home de votre site Web, puis recherchez la ligne suivante
memory_limit = 64M
Et remplacez 64M par la quantité souhaitée de tailles de fichiers 128M, 256M
2) Modification de votre fichier .htaccess.
L'édition du fichier .htaccess identique à l'édition du fichier PHP.ini,
Ajoutez simplement la ligne suivante à votre fichier .htaccess
php_value memory_limit 64M
3)Modifier le wp-config.php
Pour modifier la valeur du fichier wp-config.php, ajoutez la ligne suivante à votre fichier.
define('WP_MEMORY_LIMIT', '64M');
N'oubliez pas de remplacer le 64M par défaut par 128M et 256M.
Si vous obtenez toujours l'erreur, mieux vaut contacter votre hôte, il se fera un plaisir de vous aider à résoudre vos problèmes.
7) L'éditeur visuel ne fonctionne pas :-
C'est le problème WordPress le plus ennuyeux. Vous ne pouvez rien voir sur l'éditeur visuel même après avoir écrit les articles, mais l'éditeur de texte fonctionnera correctement. Ce problème est généralement causé par l'absence des fichiers JS requis par votre éditeur visuel. Ce problème est dû aux plugins en conflit avec votre éditeur visuel. Avant d'essayer de résoudre vos problèmes, désactivez une fois les plugins que vous utilisez pour l'édition de texte comme tinymce. pour passer à l'éditeur visuel par défaut et vérifier après avoir vidé le cache de votre navigateur et des autres navigateurs. Si le problème n'est pas résolu, vérifiez les étapes ci-dessous.
Voici comment vous pouvez résoudre ce problème.
Résolution 1 : -
Ajoutez simplement le script suivant à votre fichier wp-config.php
define('CONCATENATE_SCRIPTS', false );
Et enregistrez votre fichier.
Résolution 2 : -
Notez que dans cette étape, effectuez une sauvegarde avant de continuer
Téléchargez WordPress et téléchargez les dossiers wp-admin et wp-includes à l'aide de ftp ou de file-manger.
Résolution 3 : -
Utilisez un autre éditeur de texte que l'éditeur par défaut. Voici une excellente alternative à CKEditor.
8) Temps d'exécution maximal : -
Vous obtiendrez un message d'erreur indiquant que « Exécution maximale de 30 secondes dépassée » Lorsque vous obtenez ce message d'erreur, cela signifie que WordPress est incapable de traiter la demande dans le délai d'exécution. Vous pouvez éviter ce problème en éditant le fichier php.ini ou en éditant le fichier .htaccess
Solution 1 : Modifier le fichier php.ini
Ouvrez votre fichier php.ini qui se trouvera dans le dossier racine.
Trouvez la ligne suivante
max_execution_time = 60 ;
Solution 2:- Modification du fichier .htaccess
Ouvrez votre fichier .htaccess, puis ajoutez la ligne suivante au fichier et enregistrez.
php_value max_execution_time 60
9) Erreur 28 :
Lorsque vous rencontrez ce problème, vous obtiendrez un message d'erreur comme
Code d'erreur 28 : il n'y a plus d'espace sur l'appareil
Cela signifie que vous manquez d'espace disque sur votre hébergement. Ce problème est généralement causé par le débordement du cache et des répertoires temporaires.
Pour résoudre ce problème en exécutant une commande "repair table" dans phpMyAdmin.
Si cela n'a pas résolu le problème, vous devez contacter votre hébergeur à propos de ce problème. Pour résoudre ce problème.
Il y a tellement de problèmes qu'un utilisateur de WordPress peut rencontrer. Comme ce sont des problèmes courants que chaque utilisateur de WordPress rencontre de temps en temps.
Si vous avez plus de 2 sites et que vous ne parvenez pas à suivre les prochaines erreurs possibles que votre site WordPress pourrait générer, installez ce plugin génial WP Error plugin qui est un plugin génial qui vous aide à suivre les erreurs sur vos sites WordPress.
Si vous rencontrez d'autres problèmes avec wordpress, laissez votre commentaire ci-dessous, nous mettrons à jour l'article avec le correctif que vous recherchez.













